re = /([a-zA-Z][a-zA-Z0-9_]*)\s*=\s*(|['"])(.+)\2/
str = '#!/bin/bash
foo = "Hello world!"
bar="123"
x=1
z=\'test\'
echo -e "The value of foo is $foo\\n"
echo -e "The value of bar is $bar"
\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end