import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z][a-zA-Z0-9_]*)\\s*=\\s*(|['\"])(.+)\\2";
final String string = "#!/bin/bash\n"
+ "foo = \"Hello world!\"\n"
+ "bar=\"123\"\n"
+ "x=1\n"
+ "z='test'\n"
+ "echo -e \"The value of foo is $foo\\n\"\n"
+ "echo -e \"The value of bar is $bar\"\n"
+ "';";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}