$re = '/([a-zA-Z][a-zA-Z0-9_]*)\s*=\s*(|[\'"])(.+)\2/';
$str = '#!/bin/bash
foo = "Hello world!"
bar="123"
x=1
z=\'test\'
echo -e "The value of foo is $foo\\n"
echo -e "The value of bar is $bar"
\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);