using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z][a-zA-Z0-9_]*)\s*=\s*(|['""])(.+)\2";
string input = @"#!/bin/bash
foo = ""Hello world!""
bar=""123""
x=1
z='test'
echo -e ""The value of foo is $foo\n""
echo -e ""The value of bar is $bar""
';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}