import Foundation
let pattern = #"([a-zA-Z][a-zA-Z0-9_]*)\s*=\s*(|['"])(.+)\2"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#!/bin/bash
foo = "Hello world!"
bar="123"
x=1
z='test'
echo -e "The value of foo is $foo\n"
echo -e "The value of bar is $bar"
';
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)