const regex = /([a-zA-Z][a-zA-Z0-9_]*)\s*=\s*(|['"])(.+)\2/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z][a-zA-Z0-9_]*)\\s*=\\s*(|[\'"])(.+)\\2', 'g')
const str = `#!/bin/bash
foo = "Hello world!"
bar="123"
x=1
z='test'
echo -e "The value of foo is \$foo\\n"
echo -e "The value of bar is \$bar"
';`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}