# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)//gm;t' <<< "00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
"