# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)"
test_str = ("00:12:45\n"
"23:65:67\n"
"23:56:00\n"
"01:60:89\n"
"12:59:59\n"
"20:30:30\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.