import Foundation
let pattern = #"(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)