$re = '/(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)/m';
$str = '00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;