package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)`)
var str = `00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}