// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)").unwrap();
let string = "00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}