import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[01]\\d|2[0123]):(?:[012345]\\d):(?:[012345]\\d)";
final String string = "00:12:45\n"
+ "23:65:67\n"
+ "23:56:00\n"
+ "01:60:89\n"
+ "12:59:59\n"
+ "20:30:30\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}