package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<form.*?action="([^"]*)".*?>`)
var str = `<form id="loginForm" name="loginForm" method="post" action="M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB">
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}