const regex = /<form.*?action="([^"]*)".*?>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<form.*?action="([^"]*)".*?>', '')
const str = `<form id="loginForm" name="loginForm" method="post" action="M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}