$re = '/<form.*?action="([^"]*)".*?>/';
$str = '<form id="loginForm" name="loginForm" method="post" action="M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB">
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);