re = /<form.*?action="([^"]*)".*?>/
str = '<form id="loginForm" name="loginForm" method="post" action="M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB">
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end