import Foundation
let pattern = #"<form.*?action="([^"]*)".*?>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<form id="loginForm" name="loginForm" method="post" action="M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}