import re
regex = re.compile(r"<form.*?action=\"([^\"]*)\".*?>")
test_str = ("<form id=\"loginForm\" name=\"loginForm\" method=\"post\" action=\"M_Username_Password.aspx?__ufps=802858&84E09046BECF819E=6C1143C04AF5072F1DF5B1C51C90DACB\">\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")