using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Sec\. [A-Z\d]+\.([A-Z\d]+\.)?""\s?";
string input = @"""Sec. 1.01.""
""Sec. 47.06.""
""Sec. 71.022."" ""Sec. 611.""
""Sec. 12A.002.""
""Sec. 12A.152.""
""Sec. 50D.001.""
""Sec. I.2.""
""Sec. I.5B.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}