use strict;
my $str = '"Sec. 1.01."
"Sec. 47.06."
"Sec. 71.022." "Sec. 611."
"Sec. 12A.002."
"Sec. 12A.152."
"Sec. 50D.001."
"Sec. I.2."
"Sec. I.5B."';
my $regex = qr/"Sec\. [A-Z\d]+\.([A-Z\d]+\.)?"\s?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}