// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""Sec\. [A-Z\d]+\.([A-Z\d]+\.)?"\s?"#).unwrap();
let string = "\"Sec. 1.01.\"
\"Sec. 47.06.\"
\"Sec. 71.022.\" \"Sec. 611.\"
\"Sec. 12A.002.\"
\"Sec. 12A.152.\"
\"Sec. 50D.001.\"
\"Sec. I.2.\"
\"Sec. I.5B.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}