$re = '/"Sec\. [A-Z\d]+\.([A-Z\d]+\.)?"\s?/';
$str = '"Sec. 1.01."
"Sec. 47.06."
"Sec. 71.022." "Sec. 611."
"Sec. 12A.002."
"Sec. 12A.152."
"Sec. 50D.001."
"Sec. I.2."
"Sec. I.5B."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);