package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"Sec\. [A-Z\d]+\.([A-Z\d]+\.)?"\s?`)
var str = `"Sec. 1.01."
"Sec. 47.06."
"Sec. 71.022." "Sec. 611."
"Sec. 12A.002."
"Sec. 12A.152."
"Sec. 50D.001."
"Sec. I.2."
"Sec. I.5B."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}