const regex = /"Sec\. [A-Z\d]+\.([A-Z\d]+\.)?"\s?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"Sec\\. [A-Z\\d]+\\.([A-Z\\d]+\\.)?"\\s?', 'g')
const str = `"Sec. 1.01."
"Sec. 47.06."
"Sec. 71.022." "Sec. 611."
"Sec. 12A.002."
"Sec. 12A.152."
"Sec. 50D.001."
"Sec. I.2."
"Sec. I.5B."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}