import Foundation
let pattern = #""Sec\. [A-Z\d]+\.([A-Z\d]+\.)?"\s?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"Sec. 1.01."
"Sec. 47.06."
"Sec. 71.022." "Sec. 611."
"Sec. 12A.002."
"Sec. 12A.152."
"Sec. 50D.001."
"Sec. I.2."
"Sec. I.5B."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)