using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/(screenTranslate|translate)\((\""[A-z=\(\)\s]+\"")(, \{ ns: \""[A-z\s]+\"" })?\)/g";
string substitution = @"$2";
string input = @"translate(""taxTable"")";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}