re = /\/(screenTranslate|translate)\((\"[A-z=\(\)\s]+\")(, \{ ns: \"[A-z\s]+\" })?\)\/g/
str = 'translate("taxTable")'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result