import Foundation
let pattern = #"/(screenTranslate|translate)\((\"[A-z=\(\)\s]+\")(, \{ ns: \"[A-z\s]+\" })?\)/g"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"translate("taxTable")"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)