$re = '//(screenTranslate|translate)\((\"[A-z=\(\)\s]+\")(, \{ ns: \"[A-z\s]+\" })?\)/g/';
$str = 'translate("taxTable")';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;