# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)[ -]+(?=[a-zA-Z]\b)//g;t' <<< "Original
A-B-C SCHOOL INSTITUTION
A B C SCHOOL INSTITUTION
A 4 C SCHOOL INSTITUTION
"