#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\d)[ -]+(?=[a-zA-Z]\b)"
Local $sString = "Original" & @CRLF & _
"A-B-C SCHOOL INSTITUTION" & @CRLF & _
"A B C SCHOOL INSTITUTION" & @CRLF & _
"A 4 C SCHOOL INSTITUTION" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)