import Foundation
let pattern = #"(?<!\d)[ -]+(?=[a-zA-Z]\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Original
A-B-C SCHOOL INSTITUTION
A B C SCHOOL INSTITUTION
A 4 C SCHOOL INSTITUTION
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)