# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\d)[ -]+(?=[a-zA-Z]\b)"
test_str = ("Original\n"
"A-B-C SCHOOL INSTITUTION\n"
"A B C SCHOOL INSTITUTION\n"
"A 4 C SCHOOL INSTITUTION\n\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.