const regex = new RegExp('(?<!\\d)[ -]+(?=[a-zA-Z]\\b)', 'g')
const str = `Original
A-B-C SCHOOL INSTITUTION
A B C SCHOOL INSTITUTION
A 4 C SCHOOL INSTITUTION
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);