use strict;
my $str = 'Original
A-B-C SCHOOL INSTITUTION
A B C SCHOOL INSTITUTION
A 4 C SCHOOL INSTITUTION
';
my $regex = qr/(?<!\d)[ -]+(?=[a-zA-Z]\b)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";