re = /(?<!\d)[ -]+(?=[a-zA-Z]\b)/
str = 'Original
A-B-C SCHOOL INSTITUTION
A B C SCHOOL INSTITUTION
A 4 C SCHOOL INSTITUTION
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result