using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"order.*?(\d+)";
string input = @"orderId=669819528
url1\order679638797
url2\orders\result691272565
url2\blahblah&orderId=685442897
url4\orderId=671554945
otherone
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}