package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)order.*?(\d+)`)
var str = `orderId=669819528
url1\order679638797
url2\orders\result691272565
url2\blahblah&orderId=685442897
url4\orderId=671554945
otherone
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}