// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)order.*?(\d+)").unwrap();
let string = "orderId=669819528
url1\\order679638797
url2\\orders\\result691272565
url2\\blahblah&orderId=685442897
url4\\orderId=671554945
otherone
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}