import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "order.*?(\\d+)";
final String string = "orderId=669819528\n"
+ "url1\\order679638797\n"
+ "url2\\orders\\result691272565\n"
+ "url2\\blahblah&orderId=685442897\n"
+ "url4\\orderId=671554945\n"
+ "otherone\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}