use strict;
my $str = 'orderId=669819528
url1\\order679638797
url2\\orders\\result691272565
url2\\blahblah&orderId=685442897
url4\\orderId=671554945
otherone
';
my $regex = qr/order.*?(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}