const regex = /order.*?(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('order.*?(\\d+)', 'gm')
const str = `orderId=669819528
url1\\order679638797
url2\\orders\\result691272565
url2\\blahblah&orderId=685442897
url4\\orderId=671554945
otherone
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}