# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[|\()\s*(.*?)\s*(\]|\))/$1 $2 $3/g;t' <<< "test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done"