import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[|\\()\\s*(.*?)\\s*(\\]|\\))";
final String string = "test(option)with[something]done\n\n"
+ "test( option ) with[ something ] done\n"
+ "test( option) with[ something] done\n"
+ "test(option ) with[something ] done\n"
+ "test( option ) with[ something ] done";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}