import Foundation
let pattern = #"(\[|\()\s*(.*?)\s*(\]|\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)