using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[|\()\s*(.*?)\s*(\]|\))";
string substitution = @"$1 $2 $3";
string input = @"test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}