package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[|\()\s*(.*?)\s*(\]|\))`)
var str = `test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done`
var substitution = "$1 $2 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}