const regex = /(\[|\()\s*(.*?)\s*(\]|\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[|\\()\\s*(.*?)\\s*(\\]|\\))', 'g')
const str = `test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done`;
const subst = `$1 $2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);