re = /(\[|\()\s*(.*?)\s*(\]|\))/
str = 'test(option)with[something]done
test( option ) with[ something ] done
test( option) with[ something] done
test(option ) with[something ] done
test( option ) with[ something ] done'
subst = '$1 $2 $3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result